• /
  • EnglishEspañolFrançais日本語한국어Português
  • Se connecterDémarrer

Cette traduction automatique est fournie pour votre commodité.

En cas d'incohérence entre la version anglaise et la version traduite, la version anglaise prévaudra. Veuillez visiter cette page pour plus d'informations.

Créer un problème

Aucun problème d'autorisation de données et de clé de registre

Problème

Après avoir généré du trafic pour votre application .NET et attendu cinq minutes, les données n'apparaissent toujours pas dans l'UI de New Relic.

Solution

Important

Vérifiez auprès de votre administrateur système avant de modifier les autorisations.

  1. Assurez-vous que l'identité du pool d'applications dispose d'un accès read à la clé de registre New Relic située à l'adresse :

    HKLM\SOFTWARE\New Relic\.NET Agent\
  2. Accordez à tous les utilisateurs du système l'accès à cette clé de registre ou autorisez uniquement l'identité du pool d'applications à accéder à la clé.

  3. Depuis la ligne de commande, effectuez une IISRESET.

  4. Si la mise à jour des autorisations ne résout pas le problème, suivez les procédures de dépannage de l'agent .NET pour les données manquantes.

Conseil

Pour éviter que ce problème ne se reproduise lors des futures installations, désinstallez WSM 3.3.5.0. Si vous ne souhaitez pas apporter de modifications à votre registre, désinstallez WSM et .NET, puis réinstallez les dernières versions.

Cause

Une raison courante pour laquelle les données n’apparaissent pas est que l’agent .NET de New Relic ne peut pas accéder à ses clés de registre. Vous pouvez voir des erreurs d'autorisation de registre dans votre log de profileur à l'adresse :

%ALLUSERSPROFILE%\New Relic\.NET Agent\Logs\

Par exemple, vous pouvez voir :

[Info] ... Logger initialized
[Error] ... Unable to find New Relic Home directory in registry or environment.
[Error] ... An exception was thrown while initializing the profiler.
Droits d'auteur © 2025 New Relic Inc.

This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.