Problème
Les donnéeslog de votre application Java indiquent des échecs de connexion à New Relic. Vous souhaitez vérifier si les messages INFO
sont dus à la connectivité du trafic ou aux règles de pare-feu, ou s'ils sont dus à des problèmes plus graves.
Solution
Les échecs occasionnels de connexion au collecteur New Relic ne devraient pas être une source d'inquiétude. Ces échecs ne devraient pas affecter les métriques de performances disponibles dans l'utilisateur de l'interface New Relic de votre application.
L'agent Java de New Relic tente de se connecter environ une fois par minute. Pour résoudre le problème :
- Recherchez dans votre fichier de log
INFO
messages concernant les échecs de connexion. - Vérifiez la fréquence à laquelle les messages apparaissent.
Par exemple, recherchez des messages tels que :
Jul 31, 2017 21:37:14 +0000 NewRelic 10INFO: Failed to connect to collector.newrelic.com.:443 for My Application:java.net.ConnectException: Connection refused:connect
ou
Jul 31, 2017 21:37:14 +0000 NewRelic 40INFO: The data collector is temporarily unavailable.This can happen periodically. In the event that availability of our servers is not restored after a period of time, then please report this to New Relic.java.net.SocketException: Connection reset
Selon la fréquence à laquelle le message apparaît, procédez comme suit pour résoudre le problème :
Frequency of INFO message | Comments |
---|---|
Quelques minutes | L'agent Java de New Relic peut mettre en cache une quantité importante de données métriques lorsqu'il ne peut pas se connecter. Même si la panne dure quelques minutes, en général, cela n'entraînera aucune perte d'informations dans l'UI . Vous pouvez ignorer ces messages en toute sécurité. |
Par intermittence sur quelques jours | Des problèmes de connexion intermittents peuvent parfois provoquer l'apparition de plusieurs de ces messages en peu de temps. Si cela ne se produit qu'une fois tous les quelques jours et que toutes les données de votre application apparaissent dans l'UI de New Relic , vous pouvez ignorer ces messages en toute sécurité. |
Toutes les minutes pendant plusieurs minutes | Si des échecs se produisent toutes les minutes pendant plus de quelques minutes, l'agent Java n'est pas en mesure de recevoir des données de votre application et aucune donnée ne peut être signalée. Dans cette situation :
|
Cause
Malgré le texte log , cette erreur est généralement causée par une défaillance de connectivité ou de trafic protégé par un pare-feu plutôt que par l'indisponibilité réelle du collecteur New Relic . Pour plus d'informations, consultez les listes de plages IP utilisées par tous les services de New Relic.