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Liens d'hôte manquants dans Java de l'application APM Résumé

Problème

Prudence

La modification de vos paramètres de nom d'hôte, en particulier les paramètres FQDN, peut désactiver l'accès réseau de votre serveur. Testez soigneusement toutes les modifications avant de les déployer dans un environnement de production.

Vous ne pouvez pas afficher les liens vers vos hôtes Linux à partir de la page APM Summary de votre application Java.

Solution

Configurez les paramètres du nom d'hôte afin que l'agent Infrastructure de New Relic dans un agent environnement Linux renvoie exactement la même chaîne de nom que l'agent Java de New Relic . Recommandation : modifiez les paramètres du nom de domaine complet (FQDN). L'agent lit son nom d'hôte à partir des paramètres FQDN du système d'exploitation. Par conséquent, la définition du nom d'hôte à cet endroit garantira que les deux agents partagent un seul nom d'hôte.

Prudence

L'interface utilisateur New Relic utilise le nom d'hôte pour lier une application à son serveur hôte. La modification du nom d'hôte entraînera l'affichage d'un nom différent pour le serveur d'applications par rapport à celui signalé par les applications de monitoring. Si le lien de l'application fonctionne actuellement, changer le nom d'hôte peut rompre les liens hôte-serveur.

Cause

New Relic relie l'application et l'hôte ou le serveur ensemble en faisant correspondre la chaîne du nom d'hôte rapporté par l'agent Java et notre agent d'infrastructure pour Linux. Si ces deux chaînes de nom d’hôte ne sont pas identiques, New Relic ne peut pas connecter l’application et le serveur dans la page APM Summary .

Il y a plusieurs raisons pour lesquelles cela peut se produire. Par exemple:

  • Il se peut que la JVM signale l'adresse IP et non le nom d'hôte.
  • La JVM peut signaler une adresse IPv6, tandis que l'agent Linux signale une adresse IPv4.
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