Problème
Après avoir généré du trafic pour votre application .NET et attendu cinq minutes, les données n'apparaissent toujours pas dans l'UI de New Relic.
Solution
Important
Vérifiez auprès de votre administrateur système avant de modifier les autorisations.
Assurez-vous que l'identité du pool d'applications dispose d'un accès
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à la clé de registre New Relic située à l'adresse :HKLM\SOFTWARE\New Relic\.NET Agent\Accordez à tous les utilisateurs du système l'accès à cette clé de registre ou autorisez uniquement l'identité du pool d'applications à accéder à la clé.
Depuis la ligne de commande, effectuez une IISRESET.
Si la mise à jour des autorisations ne résout pas le problème, suivez les procédures de dépannage de l'agent .NET pour les données manquantes.
Conseil
Pour éviter que ce problème ne se reproduise lors des futures installations, désinstallez WSM 3.3.5.0. Si vous ne souhaitez pas apporter de modifications à votre registre, désinstallez WSM et .NET, puis réinstallez les dernières versions.
Cause
Une raison courante pour laquelle les données n’apparaissent pas est que l’agent .NET de New Relic ne peut pas accéder à ses clés de registre. Vous pouvez voir des erreurs d'autorisation de registre dans votre log de profileur à l'adresse :
%ALLUSERSPROFILE%\New Relic\.NET Agent\Logs\
Par exemple, vous pouvez voir :
[Info] ... Logger initialized[Error] ... Unable to find New Relic Home directory in registry or environment.[Error] ... An exception was thrown while initializing the profiler.