Problème
Selon la situation, vous pouvez trouver une trace d'erreur dans l'UI APM qui n'inclut pas de trace d'appels pour votre application .NET.
Solution
Selon la situation, suivez ces procédures de dépannage.
Cause
Le renvoi d'une erreur 500
signifie que le serveur d'application lui-même a détecté une erreur et défini le code d'état HTTPS 500
.
- Si la condition d'erreur a été détectée et gérée par la logique application , il n'y avait aucun objet d'exception et donc aucune stack.
- S'il y avait un objet d'exception à un moment donné, mais qu'il était géré en interne par le code d'application qui définissait le statut
500
sur la réponse, alors l'exception n'est jamais devenue visible pour l'agent .NET. Aucune stack n'est disponible pour que l'agent .NET puisse la signaler.
Lorsque des traces d'appels sont signalées, l'erreur résulte d'une exception qui n'a pas été détectée et gérée dans la logique du serveur application . L'agent .NET voit l'exception non gérée lors d'une transaction de monitoring, il signale donc la trace des appels.
Cependant, aucune trace d'appel n'apparaît pour les erreurs 500
car le serveur application gère les erreurs et définit ensuite le code d'état. Le code application lui-même ne conserve aucune trace d'appels.