Problème
L'agent PHP New Relic rapportait auparavant des données, mais a ensuite cessé de le faire. En outre:
- Lorsque vous avez vérifié votre agent daemon fichier de log
/var/log/newrelic/newrelic-daemon.log
, vous avez vu le messageLack of activity within 10ms
. - L'état de santé de l'application est gris.
- L'option permettant de supprimer l'application apparaît dans le menu Settings de l'application lorsque vous sélectionnez l'option icône.
Solution
Utilisez l’une de ces méthodes pour empêcher votre application d’entrer dans un état d’inactivité :
- Définissez la valeur du délai d'expiration pour
newrelic.daemon.app_timeout
sur au moins deux fois l'intervalle de vos transactions. Par exemple, pour une tâche d’arrière-plan horaire, définissez le délai d’expiration sur deux heures. - Recommandation : si vous avez des processus longs ou peu fréquents, exécutez une tâche cron toutes les cinq minutes avec une transaction simple, telle que
phpinfo()
. Cela permettra de garantir que l’application n’entre pas dans un état inactif.
Important
Ne définissez pas newrelic_ignore_transaction
pour ignorer la tâche cron. L'agent PHP entrera dans un état inactif si le travail ne s'exécute pas et ne génère pas de rapport.
Cause
Si les transactions d'une application prennent plus de dix minutes ou se produisent moins d'une fois toutes les dix minutes, l'application entre et reste dans un état inactif.
Lorsque l'agent PHP est dans un état inactif, two transactions doivent se produire avant qu'il ne recommence à générer des rapports :
- La première transaction réveille le daemon et rétablit la connexion à New Relic.
- La deuxième transaction transmet des données à New Relic.