Problème
L'agent fonctionne mais, de manière inattendue, le nom de l'entité ou le nom de l'hôte dans l'UI ou la télémétrie change pour l'agent infrastructure .
Solution
Vérifiez les paramètres du nom d’hôte dans la configuration de l’agent.
Tenez compte des directives suivantes :
- Pour les environnements cloud (AWS, Azure, GCP), assurez-vous que l'ID d' instance peut être obtenu via les métadonnées cloud , les autorisations manquantes et d'autres limitations peuvent empêcher l'agent d'obtenir les métadonnées requises.
- Si l'hôte n'est pas dans le cloud et que
display_name
n'est pas défini dans son fichier de configuration, l'agent utiliserahostname
dans le cadre de la définition du nom de l'entité. - L'agent tente d'obtenir le FQDN (nom de domaine qualifié complet), qui peut ne pas être correctement configuré dans DNS ou localement, ou il peut changer de manière dynamique dans votre environnement. Si « dns_hostname_resolution » est défini sur faux, il utilisera la résolution interne du nom d'hôte pour l'obtenir à partir du système d'exploitation.
Cause
L'agent détermine la valeur de entityName
à l'aide de la liste suivante, classée par priorité :
- ID d' instanceAWS
- Azure ID d'instance
- ID d' instanceGCP
- Identifiant d' instanceAlibaba
- Nom d'affichage
- Nom d'hôte court
Il revient à la valeur suivante en priorité si elle n'est pas définie. Si l’une de ces valeurs change, le entityName
changera dynamiquement.