• /
  • EnglishEspañolFrançais日本語한국어Português
  • Se connecterDémarrer

Cette traduction automatique est fournie pour votre commodité.

En cas d'incohérence entre la version anglaise et la version traduite, la version anglaise prévaudra. Veuillez visiter cette page pour plus d'informations.

Créer un problème

Nom d'hôte incorrect signalé

Problème

L'agent fonctionne, mais l'UI d'infrastructure affiche un nom d'hôte incorrect ou des hôtes dupliqués apparaissent.

Solution

Vérifiez les paramètres liés au nom d’hôte dans la configuration de l’agent. Pour définir le nom d’hôte correct, essayez les étapes suivantes :

  1. Modifiez le newrelic-infra.yml configuration fichier et ajoutez override_hostname l'option, dont la valeur est votre nom d'hôte attendu. Par exemple:

    override_hostname: correct-host.domain.com
  2. Utilisez votre système d’initialisation pour redémarrer le service de l’agent :

Cause

Sous Linux et macOS, l'agent New Relic Infrastructure tente de résoudre son nom de domaine complet par rapport à un serveur de noms de domaine, qui peut ne pas être correctement configuré ou ne pas être contrôlé par le même utilisateur que l'agent New Relic Infrastructure. Sous Windows, il résout le nom de domaine à l’aide d’outils internes.

Droits d'auteur © 2025 New Relic Inc.

This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.