Problème
L'agent fonctionne mais certaines données d'inventaire ou métadonnées semblent incorrectes et la mise en cache locale empêche l'envoi de données correctes depuis l'agent infrastructure .
Solution Linux
Arrêtez l'agent d'infrastructure
sudo systemctl stop newrelic-infra
Supprimer les fichiers temporaires
sudo rm -rf /var/db/newrelic-infra/data
Démarrer l'agent d'infrastructure
sudo systemctl start newrelic-infra
Solution Windows
Dans une prompt PowerShell de l'administrateur, arrêtez l'agent d'infrastructure
net stop newrelic-infra
Supprimer les fichiers temporaires
Remove-Item -Path “C:\ProgramData\New Relic\newrelic-infra\data” -Recurse -Force
Démarrer l'agent d'infrastructure
net start newrelic-infra
Cause
L'agent met en cache localement les métadonnées et les données d'inventaire, pour déterminer quel delta envoyer. Dans certaines situations, il peut être souhaitable de réinitialiser ce cache/état local, afin que toutes les données soient envoyées.